Skip to content


TEKIAMI
vodoun
Posts: 17
Registered: ‎04-12-2011
Accepted Solution

Trend Micro Devs going to have kittens? Firefox 5 released

Now that Firefox 5 is out and it's not that long ago since the Trend Micro toolbar extension was updated for Firefox 4. Now reading peoples extensions incompatible for now... I wonder if Trend Micro is in the running as well.

Please use plain text.
Trend Micro Employee
chaste02
Posts: 289
Registered: ‎08-18-2009

Re: Trend Micro Devs going to have kittens? Firefox 5 released

Hi vodoun,

 

Supportability for Firefox 5 and 6 is already in the readiness activities for Titanium. The feedback from TM Community really help a lot in making sure that Trend Micro development team is ready for future releases.

 

However, since the Firefox 5 that was released recently is not the official/final build, TM Devs cannot finalize the compatible modules for the fix. They are waiting for the final build of Firefox 5 to test the fix and eventually deploy via Hotfix or Active Update.


I am a Trend Micro employee. My comments and advice come from my personal knowledge and experience. I’m happy to volunteer what I can to help others have a great Trend Micro experience.
Please use plain text.
Stone Emissary yyz
Stone Emissary
yyz
Posts: 29
Registered: ‎08-21-2010

Re: Trend Micro Devs going to have kittens? Firefox 5 released

I read that Mozilla is now on a 3 month version run. So 6 will be out in September. I guess they're trying to catch up to Chrome version #. Too bad speed and user interface will never catch up.

 

Please use plain text.
Stone Emissary
Jrmacdonald
Posts: 8
Registered: ‎03-22-2011

TITANIUM Toolbar Not compatible with Firefox 5.0

Trend micro i am really getting quite irritated at how you update at a very slow pace when a new update comes out it takes about 5 weeks or even longer for you to update and by the time its updated for that version a new browser update is out and its not compatible

if you want money from my wallet you have to do something about this or i will change to another program

 

Please use plain text.
Honored Esquire
dmccann
Posts: 116
Registered: ‎08-22-2010

Re: TITANIUM Toolbar Not compatible with Firefox 5.0

Jrmacdonald-- I share your frustration.  Firefox has as much market penetration as Explorer and is being treated as though it is some niche program by Trends development team.  I use Firefox because it so much faster than anything else.  I also use Trend Micro because it is considerably faster than anything else and untill recently provided excelent protection for my needs.  But I am getting tired of seeing all of my Internet safety progams (Iconix, Guarded ID, Trend Micro Toolbar, Trend Micro NSC extension) greyed out and disabled because they are incompatible.  The promised mid June update to make Ti compatible with FF4 never happened (although there was a hotfix posted) but it has already been made obsolete by FF5.

Please use plain text.
Trend Micro Employee
loidas
Posts: 97
Registered: ‎07-12-2010

Re: TITANIUM Toolbar Not compatible with Firefox 5.0

Hi dmccann,

 

I do understand your frustration and we are really trying our very best to cope up with every updates that web browsers have.

 

Yes you are right that there's a hot fix released for the Firefox 4 so that has been resolved.  Right now we're still working on the latest version that they will have.  The Firefox 5 is still on its beta stage so there's still no official build yet released and we cannot do some necessary hot fix yet for that version. I know soon we will be but I hope you will be patient with this.

 

We wanted our clients to be protected and that's for sure and we appreciate your support to our program.  Rest assured that we won't let you down with this.  Just wait for the hot fixes that will be released on the days to come.

 

Cheers!


I am a Trend Micro employee. My comments and advice come from my personal knowledge and experience. I’m happy to volunteer what I can to help others have a great Trend Micro experience.
Please use plain text.
Stone Emissary
kiwi4life
Posts: 21
Registered: ‎07-02-2011

New to forum & questions for Trend Micro Titanium Internet Security 2011

Hi every1 :smileyhappy:. I am new in this forum, so thank you for welcoming me :smileyhappy:.

 

Yesturday I installed Trend Micro Titanium Interent Security 2011, and I have firefox 5. 1st thing i noticed that Trend Micro NSC Firefox Extension 6.5.0.1234 is disabled and it is not compatible with firefox 5. So can you please fix this issue. Thanks.

 

One other thing, should i turn on my Windows Firewall and activate the firewall booster in Trend Micro! Lets say i turned on my Trend Micro firewall booster, should i also turn on the windows firewall as well. Will it cause conflict? Thanks.

Please use plain text.
Master Esquire Neo
Master Esquire
Neo
Posts: 287
Registered: ‎01-23-2010

Re: New to forum & questions for Trend Micro Titanium Internet Security 2011

Hello kiwi4life

 

As for the Trend Micro Toolbar for Firefox 5 they;re working to make it Compatible with Firefox 5

 

as for Firewall Booster it is designed to work with Windows Personal Firewall it means that you should Enable Windows Firewall and Firewall Booster to work together .... :smileyhappy: there is not any conflict betwen them  

Please use plain text.
Stone Emissary
kiwi4life
Posts: 21
Registered: ‎07-02-2011

Re: New to forum & questions for Trend Micro Titanium Internet Security 2011

[ Edited ]

 

Oh thanks, for your message :smileyhappy:.  Another thing that i forgot to mention. When i sign in to my trend micro account i can see that an download is avalaible the version is 3.1. I installed trend micro from cd that i bought it from shop. It is already version 3.1. Should i still need to download it from my account, am confused? What is that download about? Yesturday i downloaded that thing, but i didn't install!

 

One other thing, so is it okay to enable Windows Defender, I am using Windows Vista SP2. Also I am not happy :smileysad: of Trend Micro Titanium Interent Security 2011 of causing a conflict with MalwareBytes' Antimalware and it had to uninstall it prior to installing Trend Micro Titanium Internet Security 2011. Other internet security/antivirus doesn't cause a conflict with that and can be used alongside. I want Trend Micro to fix this issue as well, please :smileysad:. Thanks.

Please use plain text.
Trend Micro Employee
loidas
Posts: 97
Registered: ‎07-12-2010

Re: New to forum & questions for Trend Micro Titanium Internet Security 2011

Hi kiwi4life,

 

In terms of the version 3.1, whenever the program updates it downloads the latest version of the program.  It only means that you are already running the 3.1 version. 

 

You may check the version of your program by doing the following steps:

1. Open the Trend Micro Main Console.

2. Click on the (?) at the upper right hand corner.

3. Select About.

 

It will therefore run an update and check the version, if it's 3.1 then you've got nothing to worry about.

 

As for MalwareBytes' Antimalware, unfortunately we can not do some necessary changes with that since the program have the same functionality as the Trend Micro Titanium Internet Security.  They both have the same antivirus and antispyware protection and would be redundant to have both programs installed.

 

It is nice to know that you have some several recommendations about our product and we value that.

 

Cheers!

 

 


I am a Trend Micro employee. My comments and advice come from my personal knowledge and experience. I’m happy to volunteer what I can to help others have a great Trend Micro experience.
Please use plain text.