Skip to content


Reply
Stone Emissary
asigurds
Posts: 7
Registered: ‎07-08-2010
Accepted Solution

Unable to install Build 1895 on OS 10 server

I've been trying to install build 1895 on my OS 10 server hoping to resolve some performance issues on clients.

But the update fails with the messaga that SP1 is not installed on the server.

I used the "OSCE_10_WIN_ServicePack1_SinglePackage_R4_(en).zip" download, to install the server.

"About" from the Web Console gives the following information:

 

OfficeScan Server
Version:

10.0 Service Pack 1

Build:

1736


Integrated Smart Scan Server
Version:

1.0

Build:

1289

 

Which indicates that SP1 is already installed.

If I try to reinstall SP1 with the "OSCE_10_WIN_ServicePack1_R4_(en).exe" download, it fails with the message "installation terminated by user", and the log is:

 

-> Run PostTmPatch.exe to customize actions
-> Check operating system - WIN2008_R2_64 (Failed)
-> Check program version - 10.0
-> Check program language type - en
-> Check OfficeScan free disk space. - C:\Program Files (x86)\Trend Micro\OfficeScan\PCCSRV\
-> Check OfficeScan free disk space. - C:\Program Files (x86)\Trend Micro\OfficeScan\PCCSRV\
-> Checking if critical patch build 1257 is already installed - (Failed)
-> Checking if a newer service pack is already installed - (Failed)
-> Checking if a newer service pack is already installed - (Failed)
-> Checking if firewall service is enabled - 1
-> Checking OfficeScan information - 0 (Failed)
-> Run PostTmPatchDlg.exe to get SPN settings
-> Checking SPN setting - 1 (Failed)
(empty) - 1
-> Backup RBA information
-> Checking Smart Scan Server information - 1
-> Stop Trend Micro Smart Scan Server Service
-> Stop Apache2 Service
-> Stop CM Agent Service
-> Stop OfficeScan Active Directory Integration Service
-> Stop OfficeScan Master Service
-> Stop OfficeScan Plug-in Manager
- The specified service does not exist as an installed service.

-> Wait for service to be fully stopped
-> Create backup folder
Rollback:-> Create backup folder
Rollback:-> Wait for service to be fully stopped
Rollback:-> Stop OfficeScan Master Service
Rollback:-> Stop OfficeScan Active Directory Integration Service
Rollback:-> Stop CM Agent Service
Rollback:-> Stop Apache2 Service
Rollback:-> Stop Trend Micro Smart Scan Server Service
Rollback:-> Backup RBA information
Rollback:-> Run PostTmPatchDlg.exe to get SPN settings
Rollback:-> Run PostTmPatch.exe to customize actions
Installation terminated by user!

Looks like it's failing because the Plug-in Manager is missing.

 

If I try to install Plug-in Manager it fails with the message: "Installation cannot proceed", and it should be installed locally. But I'm actually installing directly on the server.

A snip from the PLM_Setup.log:

 

CustomAction CheckOsceExistence returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (c) (54:C8) [13:50:46:962]: NOTE: custom action CheckOsceExistence unexpectedly closed the hInstall handle (type MSIHANDLE) provided to it. The custom action should be fixed to not close that handle.
Action ended 13:50:46: CheckOsceExistence. Return value 3.
MSI (c) (54:24) [13:50:46:977]: Doing action: SetupCompleteError
Action 13:50:46: SetupCompleteError.
Action start 13:50:46: SetupCompleteError.

Not sure what this means.

 

Any help is appreciated.

 

PS. the OS 10 server is running on a Windows 2008 R2 server.

Please use plain text.
Trend Micro Employee
MikaNish
Posts: 10
Registered: ‎07-12-2010

Re: Unable to install Build 1895 on OS 10 server

You don't need the plugin manager to be installed to install patch 1 for officescan sp1.

 

When a service pack or patch is applied, it stops the related services, replaces specific files, and then starts the services. Issues in patch installations usually happen when another process or application is using the file so that it is locked with the process and could not be replaced by the patch setup.

To see what processes or applications are using the file, you can do the following:

 

1.Download the process explorer tool from Microsoft.

  link: http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx

2.Stop all the related Trend Micro services on the server.

3.Stop the World Wide Web Publishing service.

4.go to task manager and then kill or stop dbserver.exe.

5.Run the process explorer tool and then click on the Agree button.

6.On the menu, click Find. Select find handle or dll and then type in “PCCSRV”.

Note: This search will display any file inside the product directory that are still locked or being used. You can then temporarily kill or stop the processes or services.

7.Run the patch application again.


I am a Trend Micro employee. My comments and advice come from my personal knowledge and experience. I’m happy to volunteer what I can to help others have a great Trend Micro experience.
Please use plain text.
Stone Emissary
asigurds
Posts: 7
Registered: ‎07-08-2010

Re: Unable to install Build 1895 on OS 10 server

Thanks for the information and the reply, but unfortunately I'm still unable to install either SP1 or SP1 Patch1 as it fails in the same way as before, even after making sure no process is locking anything in the PCCSRV directory.

Please use plain text.
Trend Micro Employee
MikaNish
Posts: 10
Registered: ‎07-12-2010

Re: Unable to install Build 1895 on OS 10 server

Can you please check the follow registry :

 

\HKLM\Software\TrendMicro\OfficeScan\service\Information

 

String Value

ServicePack_Build    :    1736

 

Dword Value

ServicePack_VersionNumber     :     1

 

If the two entries are not present  just add them manually, restart the OSCE master service and proceed with the installation of the hotfix afterwards.


I am a Trend Micro employee. My comments and advice come from my personal knowledge and experience. I’m happy to volunteer what I can to help others have a great Trend Micro experience.
Please use plain text.
Trend Micro Employee
MikaNish
Posts: 10
Registered: ‎07-12-2010

Re: Unable to install Build 1895 on OS 10 server

Can you please check the follow registry : 

\HKLM\Software\TrendMicro\OfficeScan\service\Information

String Value

ServicePack_Build    :    1736

Dword Value

ServicePack_VersionNumber     :     1

 

If the two entries are not present  just add them manually, restart the OSCE master service and proceed with the installation of the hotfix afterwards.


I am a Trend Micro employee. My comments and advice come from my personal knowledge and experience. I’m happy to volunteer what I can to help others have a great Trend Micro experience.
Please use plain text.
Stone Emissary
asigurds
Posts: 7
Registered: ‎07-08-2010

Re: Unable to install Build 1895 on OS 10 server

The registry hive for OfficeScan was indeed missing (there was no OfficeScan entry at all). But it still fails with the message : "OfficeScan 10.0 service pack 1 is not installed on the server computer. Installation of Service Pack 1 Patch 1 will now terminate. The computer has not been modified."

 

This is contents of the log window:

 

-> Check operating system - UNKNOWN (Failed)
-> Check program version - 10.0
-> Check program language type - en
-> Check OfficeScan free disk space. - C:\Program Files (x86)\Trend Micro\OfficeScan\PCCSRV\
-> Checking if service pack 1 is already installed - (Failed)
Installation terminated by user!

 

This is the current OfficeScan registry entry:

 

[HKEY_LOCAL_MACHINE\SOFTWARE\TrendMicro]

[HKEY_LOCAL_MACHINE\SOFTWARE\TrendMicro\OfficeScan]

[HKEY_LOCAL_MACHINE\SOFTWARE\TrendMicro\OfficeScan\service]

[HKEY_LOCAL_MACHINE\SOFTWARE\TrendMicro\OfficeScan\service\Information]
"ServicePack_Build"="1736"
"ServicePack_VersionNumber"=dword:00000001

 

 

Please use plain text.
Stone Emissary
asigurds
Posts: 7
Registered: ‎07-08-2010

Re: Unable to install Build 1895 on OS 10 server

Solved by uninstalling the OfficeScan server and then reinstall...

Please use plain text.
Moderator Emeritus
JSMO
Posts: 960
Registered: ‎08-12-2009

Re: Unable to install Build 1895 on OS 10 server

Thank you for Reporting back!!

Please use plain text.